re = /^methods\/[^\/\n]+$/m
str = 'methods/english/dummy
methods/english
methods/french
methods
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end