#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:[^\n][\n]?)+) #flashcard ?\n*((?:\n(?:^.{1,3}$|^.{4}(?<!<!--).*))+)"
Local $sString = "- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao #flashcard" & @CRLF & _
"" & @CRLF & _
"(tab)- Empresário rural e ao" & @CRLF & _
"" & @CRLF & _
"(tab)- Pequeno empresário" & @CRLF & _
"" & @CRLF & _
"group 1:- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao" & @CRLF & _
"" & @CRLF & _
"group 2:" & @CRLF & _
"(tab)- Empresário rural e ao" & @CRLF & _
"(tab)- Pequeno empresário"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")