re = /((?:[^\n][\n]?)+) #flashcard ?\n*((?:\n(?:^.{1,3}$|^.{4}(?<!<!--).*))+)/m
str = '- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao #flashcard
(tab)- Empresário rural e ao
(tab)- Pequeno empresário
group 1:- Art. 970. A lei assegurará tratamento Favorecido, Diferenciado e Simplificado ao
group 2:
(tab)- Empresário rural e ao
(tab)- Pequeno empresário'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end