using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"exceptions.sessionException:(?<error>[\s\w-]+)\b(?=\s+at\s+com\.)";
string input = @"com.jav.orgs.exceptions.sessionException: A1234- problem accessing the session at com.jav.orgview.OpenSessionJVM(JVM Method)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}