$re = '/exceptions.sessionException:(?<error>[\s\w-]+)\b(?=\s+at\s+com\.)/m';
$str = 'com.jav.orgs.exceptions.sessionException: A1234- problem accessing the session at com.jav.orgview.OpenSessionJVM(JVM Method)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);