package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:o|(o(?1)?o))\b`)
var str = `o (1) ooo (3) oooooo (6) oooo (4) ooooooooo (9) oo (2) oooooooooooo (12) oooooooo (8) oooooooooooooooo (16) oooooooooooooooooooooooo (24) oooooooooooooooooooooooooooooooo (32)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}