$re = '/\b(?:o|(o(?1)?o))\b/';
$str = 'o (1) ooo (3) oooooo (6) oooo (4) ooooooooo (9) oo (2) oooooooooooo (12) oooooooo (8) oooooooooooooooo (16) oooooooooooooooooooooooo (24) oooooooooooooooooooooooooooooooo (32)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);