use strict;
my $str = '######## Most cases are likes this: ###############
HRB 21156
HRB, 1234
HRB: 99887
######## Some cases can be likes this: ###############
######## How to I catch the numbers as shown above? ##########
HRB-Nummer 21156
HRB-Nr. 12345
HRB-Nr: 21156
HRB Nr. 21156
HRB Nr: 21156
HRB Nr.: 21156
HRB Nummer 21156
';
my $regex = qr/\bHRB[.,: \w-]*\b(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}