# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bHRB[.,: \w-]*\b(\d+)"
test_str = ("######## Most cases are likes this: ###############\n\n"
"HRB 21156\n"
"HRB, 1234\n"
"HRB: 99887\n\n"
"######## Some cases can be likes this: ###############\n"
"######## How to I catch the numbers as shown above? ##########\n"
"HRB-Nummer 21156\n"
"HRB-Nr. 12345\n"
"HRB-Nr: 21156\n"
"HRB Nr. 21156\n"
"HRB Nr: 21156\n"
"HRB Nr.: 21156\n"
"HRB Nummer 21156\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.