use strict;
my $str = '<!DOCTYPE html>
<html lang="en">
<head>
<title>Whatever</title>
</head>
<body>
<section class="all-classes" id="section1-do-not-remove-section">
content2
content
</section>
<section class="all-classes" id="section2">
content
content2
</section>
</body>
<section class="all-classes" id="section3">
content
<div class="all-classes" id="section4">
anything
whatever
</div>
</section>
<section class="all-classes" id="section5-do-not-remove-section">
content
</section>
<section class="all-classes" id="section6">
content
</section>
<section class="all-classes" id="section7">
content
</section>
';
my $regex = qr/<section.*id="section[\d]*"[\s\S]*?<\/section>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}