# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<section.*id=\"section[\d]*\"[\s\S]*?<\/section>"
test_str = ("<!DOCTYPE html>\n"
"<html lang=\"en\">\n"
"<head>\n"
" <title>Whatever</title>\n"
"</head>\n"
"<body>\n"
" <section class=\"all-classes\" id=\"section1-do-not-remove-section\">\n"
" content2\n"
" content\n"
" </section>\n"
" <section class=\"all-classes\" id=\"section2\">\n"
" content\n"
" content2\n"
" </section>\n"
"</body>\n"
"<section class=\"all-classes\" id=\"section3\">\n"
" content\n"
" <div class=\"all-classes\" id=\"section4\">\n"
" anything\n"
" whatever\n"
" </div>\n"
"</section>\n"
"<section class=\"all-classes\" id=\"section5-do-not-remove-section\">\n"
" content\n"
"</section>\n"
"<section class=\"all-classes\" id=\"section6\">\n"
" content\n"
"</section>\n"
"<section class=\"all-classes\" id=\"section7\">\n"
" content\n"
"</section>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.