$re = '/\b(text-[\w-]*0)\b/m';
$str = '<div class="text-slate-500 text-white text-5xl bg-white bg-slate-600 bg-red/5 ....."> </div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);