// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(text-[\w-]*0)\b").unwrap();
let string = "<div class=\"text-slate-500 text-white text-5xl bg-white bg-slate-600 bg-red/5 .....\"> </div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}