package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).`)
var str = `Quisque et pharetra sapien. Aenean nunc leo, volutpat vel odio id, facilisis scelerisque lorem. Vivamus mollis vitae diam quis consequat. Vestibulum ut pulvinar risus. Nulla blandit nec velit at efficitur. Fusce convallis vehicula tellus et tempus. Aenean ac mattis felis, ac volutpat odio. Aenean faucibus tellus eget sodales gravida. Nulla nec malesuada sapien. Nullam sollicitudin lacus a sem congue, quis molestie dui mollis. Phasellus ornare iaculis diam sit amet posuere.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}