import Foundation
let pattern = #"."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Quisque et pharetra sapien. Aenean nunc leo, volutpat vel odio id, facilisis scelerisque lorem. Vivamus mollis vitae diam quis consequat. Vestibulum ut pulvinar risus. Nulla blandit nec velit at efficitur. Fusce convallis vehicula tellus et tempus. Aenean ac mattis felis, ac volutpat odio. Aenean faucibus tellus eget sodales gravida. Nulla nec malesuada sapien. Nullam sollicitudin lacus a sem congue, quis molestie dui mollis. Phasellus ornare iaculis diam sit amet posuere."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)