$re = '/^\d{0,5}\s\-\s\d{0,2}\/\d{0,2}\/\d{4}$/m';
$str = '25000 - 10/10/2021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);