#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z0-9]{64}=(~|\^|\||&|[A-z0-9]{64})"
Local $sString = "a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03=a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03^a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf" & @CRLF & _
"a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03=~a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03" & @CRLF & _
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=~(a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00)" & @CRLF & _
"a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf=~a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf" & @CRLF & _
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00|a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00" & @CRLF & _
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549^a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03" & @CRLF & _
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549&a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00" & @CRLF & _
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549" & @CRLF & _
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=~(a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00)" & @CRLF & _
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=~(a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549&a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549)" & @CRLF & _
"a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03=a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03|a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00" & @CRLF & _
"a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf=a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf&a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549" & @CRLF & _
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00" & @CRLF & _
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=~(a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549&a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549)" & @CRLF & _
"a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf=a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf^a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03" & @CRLF & _
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549^a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00" & @CRLF & _
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=~(a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf)" & @CRLF & _
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00|a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")