import re
regex = re.compile(r"[a-z0-9]{64}=(~|\^|\||&|[A-z0-9]{64})", flags=re.MULTILINE)
test_str = ("a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03=a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03^a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf\n"
"a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03=~a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03\n"
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=~(a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00)\n"
"a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf=~a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf\n"
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00|a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00\n"
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549^a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03\n"
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549&a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00\n"
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549\n"
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=~(a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00)\n"
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=~(a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549&a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549)\n"
"a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03=a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03|a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00\n"
"a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf=a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf&a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549\n"
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00\n"
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=~(a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549&a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549)\n"
"a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf=a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf^a34cffe6a40e642fb7a4c101516ea0ed06eaef08c096c7f96656ca7913debc03\n"
"a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549^a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00\n"
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=~(a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00&a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf)\n"
"a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00=a18e9f89e839061e45c759ab01c2b5a56ad84d01b2e68830f070581d56214f00|a16cb280d0c47675ef1983a69f9fadd2f6f304f7a78b329ed934868ae97d59bf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")