# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.+?)(?:,|$)"
test_str = ("3345 Michelson Drive, Suite 400, Irvine, CA 92612\n"
"12303 Airport Way, Suite 250, Broomfield, CO 80021\n"
"Two North Riverside Plaza, Suite 1430, Chicago, IL 60606\n"
"#twentytwo Northumberland Drive, Apostrophe 55, Moon, MN 13145\n"
"!Variety Coffe Cup, Potraiture 247, Mars, MS 88888\n"
".* Everywhere, Nowhere 123, Eternity, ET 12345")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.