// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+?)(?:,|$)").unwrap();
let string = "3345 Michelson Drive, Suite 400, Irvine, CA 92612
12303 Airport Way, Suite 250, Broomfield, CO 80021
Two North Riverside Plaza, Suite 1430, Chicago, IL 60606
#twentytwo Northumberland Drive, Apostrophe 55, Moon, MN 13145
!Variety Coffe Cup, Potraiture 247, Mars, MS 88888
.* Everywhere, Nowhere 123, Eternity, ET 12345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}