import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12})|(_(.){3,})|((\\$)(.+)|(.+)(\\$))";
final String string = "0e03dfdb-5da2-4167-ab2f-08d3e8f6db6c\n"
+ "0ea62b35-2c70-4e21-2ffd-08d3e62bd454\n"
+ "0f60ba13-e8ad-45dc-5479-08d3eb558eb1\n"
+ "0f8ff43d-3a90-4b0c-9390-08d3e13712c0\n"
+ "0fc8ca8b-418d-4c63-2b8e-08d3e933f221\n"
+ "10112770-4b4a-4b9f-b4bb-08d3e91e380c\n"
+ "1016f4ef-4a87-4081-6505-08d3f575421e\n"
+ "104ba594-900d-4162-ff57-08d3fd6de3d0\n"
+ "_zeus\n"
+ "_zeusweb\n"
+ "_zoyager\n"
+ "__vmware_xyz\n"
+ "somename123$\n"
+ "$someothername123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}