// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12})|(_(.){3,})|((\$)(.+)|(.+)(\$))").unwrap();
let string = "0e03dfdb-5da2-4167-ab2f-08d3e8f6db6c
0ea62b35-2c70-4e21-2ffd-08d3e62bd454
0f60ba13-e8ad-45dc-5479-08d3eb558eb1
0f8ff43d-3a90-4b0c-9390-08d3e13712c0
0fc8ca8b-418d-4c63-2b8e-08d3e933f221
10112770-4b4a-4b9f-b4bb-08d3e91e380c
1016f4ef-4a87-4081-6505-08d3f575421e
104ba594-900d-4162-ff57-08d3fd6de3d0
_zeus
_zeusweb
_zoyager
__vmware_xyz
somename123$
$someothername123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}