using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(d[oôö]g)";
string input = @"I think Ruth's dog is cuter DOG than your dog! to Dog to dog. And dôg.
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}