$re = '/(d[oôö]g)/mi';
$str = 'I think Ruth\'s dog is cuter DOG than your dog! to Dog to dog. And dôg.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);