import re
regex = re.compile(r"^(.+)$", flags=re.MULTILINE)
test_str = ("03/01/2022,7−ELEVEN − TTSH LEV SINGAPORE SG,,SGD 1.10\n"
"03/01/2022,7−ELEVEN − TTSH LEV SINGAPORE SG,,SGD 2.00\n"
"03/01/2022,HEAVENLYWANG@HWMW SINGAPORE SG,,SGD 10.60\n"
"03/01/2022,DON DON DONKI SINGAPORE SG,,SGD 11.60\n"
"03/01/2022,LIFELINE CORPORATIO SINGAPORE SG,,SGD 106.00\n"
"04/01/2022,ESSO−CHEERS BY FP SINGAPORE SG,,SGD 2.50\n"
"04/01/2022,MCDONALD'S (QSC) SINGAPORE SG,,SGD 7.10\n"
"04/01/2022,SHELL PAYA LEBAR MA SINGAPORE SG,,SGD 17.35\n"
"03/01/2022,PAYMENT − THANK YOU 8,978.47CR\n"
"04/01/2022,SINGPOST − SAM KIOS SINGAPORE SG,,SGD 2.40\n"
"04/01/2022,Artisan Boulangerie Singapore SG,,SGD 9.94\n"
"05/01/2022,W S GO & ASSOCIATES SINGAPORE SG,,SGD 374.50\n"
"06/01/2022,ECCELLENTE MARINA SINGAPORE SG,,SGD 1.90\n"
"06/01/2022,COLD STORAGE−GREAT SINGAPORE SG,,SGD 16.10\n"
"06/01/2022,STARBUCKS@GREAT WLD SINGAPORE SG,,SGD 18.00\n"
"06/01/2022,STARBUCKS@GREAT WLD SINGAPORE SG,,SGD 18.00\n"
"06/01/2022,HIRAKI SINGAPORE SG,,SGD 30.48\n"
"06/01/2022,SINGAPORE NATIONAL SINGAPORE SG,,SGD 154.08\n"
"07/01/2022,KRAFTWICH @ PLSQ SINGAPORE SG,,SGD 20.30\n"
"07/01/2022,KIM CHOO HOLDINGS P SINGAPORE SG,,SGD 33.00\n"
"08/01/2022,STARBUCKS@WIKIE EDG SINGAPORE SG,,SGD 18.00\n"
"10/01/2022,ECCELLENTE MARINA SINGAPORE SG,,SGD 1.90\n"
"10/01/2022,MCDONALD'S (PSA) SINGAPORE SG,,SGD 17.80\n"
"11/01/2022,BRAWN AND BRAINS SINGAPORE SG,,SGD 31.90\n"
"11/01/2022,12 Jan A POKE THEORY−TRIPL SINGAPORE SG,,SGD 16.50")
subst = "$1 DR"
result = regex.sub(subst, test_str)
if result:
print(result)