using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(подрост:\s+)(?<COMPOSITION>[0-9А-Я]+)?\s?(?<AGE>\(\d+\))?\s?(?<HEIGHT>\d+,\d\sм)?\s?,?\s?(?<STEMCOUNT>\d+,\d\s+тыс.шт\/га),?(?<GRADE>[А-Яа-я]+)?";
string input = @"подрост: 10Е (20) 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 1,5 тыс.шт/га
подрост: 6ЯС3И1ОР (15) 2,0 м, 3,0 тыс.шт/га,благонадежный";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}