$re = '/(подрост:\s+)(?<COMPOSITION>[0-9А-Я]+)?\s?(?<AGE>\(\d+\))?\s?(?<HEIGHT>\d+,\d\sм)?\s?,?\s?(?<STEMCOUNT>\d+,\d\s+тыс.шт\/га),?(?<GRADE>[А-Яа-я]+)?/m';
$str = 'подрост: 10Е (20) 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 3,0 м, 1,5 тыс.шт/га
подрост: 10Е 1,5 тыс.шт/га
подрост: 6ЯС3И1ОР (15) 2,0 м, 3,0 тыс.шт/га,благонадежный';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);