#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![\u4E00-\u9FAF\u3040-\u3096\u30A1-\u30FA\uFF66-\uFF9D\u31F0-\u31FF])(?<!\d)(?<!\d\.)(\d+(?:\.\d+)?m2)"
Local $sString = ""110.94m2・129.24m2";" & @CRLF & _
" --> 110.94m2 and 129.24m2" & @CRLF & _
""81.95m2(24.78坪)、うち2階車庫8.9m2" " & @CRLF & _
" --> 81.95m2" & @CRLF & _
""80.93m2(登記)"" & @CRLF & _
" --> 80.93m2" & @CRLF & _
""93.42m2・93.85m2(登記)"" & @CRLF & _
" --> 93.42m2 and 93.85m2" & @CRLF & _
""81.82m2(実測)"" & @CRLF & _
" --> 81.82m2" & @CRLF & _
""81.82m2(実測)、うち1階車庫7.82m2"" & @CRLF & _
" --> 81.82m2" & @CRLF & _
""90.11m2(実測)、うち1階車庫8.07m2"" & @CRLF & _
" --> 90.11m2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")