import Foundation
let pattern = #"(?<![\u4E00-\u9FAF\u3040-\u3096\u30A1-\u30FA\uFF66-\uFF9D\u31F0-\u31FF])(?<!\d)(?<!\d\.)(\d+(?:\.\d+)?m2)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"110.94m2・129.24m2";
--> 110.94m2 and 129.24m2
"81.95m2(24.78坪)、うち2階車庫8.9m2"
--> 81.95m2
"80.93m2(登記)"
--> 80.93m2
"93.42m2・93.85m2(登記)"
--> 93.42m2 and 93.85m2
"81.82m2(実測)"
--> 81.82m2
"81.82m2(実測)、うち1階車庫7.82m2"
--> 81.82m2
"90.11m2(実測)、うち1階車庫8.07m2"
--> 90.11m2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)