# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.\d{1,3}\B\K(?!\d)/ /gm;t' <<< "1.9 Beef Curry
1.10Banana Pie
1.11 Corn Gravy
"