$re = '/\.\d{1,3}\B\K(?!\d)/m';
$str = '1.9 Beef Curry
1.10Banana Pie
1.11 Corn Gravy
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;