#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*name[%=]([^&\n]+)"
Local $sString = "http://bunnytalks.com/goingOn?name=Bunny&phone=2340" & @CRLF & _
"http://bunnytalks.com/goingOn?name=Bunny" & @CRLF & _
"http://bunnytalks.com/goingOn?name=Talks/whatson%goingOn%name%Bunny" & @CRLF & _
"http://bunnytalks.com/goingOn?name=Talks/whatson%goingOn%name%Bunny&phone=2340"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")