using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http(s)?:\/\/([a-z0-9.]*)(:\d{0,5})?,?)*$";
string input = @"http://192.168.1.100:32400,http://192.168.1.100:32400,http://sasdfds.com
http://192.168.1.100:32400
https://192.168.1.100:32400
http://adomain.com:32400
https://adomain.com:32400
https://192.168.1.100:32400
http://adomain.com:32400
https://adomain.com:32400
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}