import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http(s)?:\\/\\/([a-z0-9.]*)(:\\d{0,5})?,?)*$";
final String string = "http://192.168.1.100:32400,http://192.168.1.100:32400,http://sasdfds.com\n"
+ "http://192.168.1.100:32400\n"
+ "https://192.168.1.100:32400\n"
+ "http://adomain.com:32400\n"
+ "https://adomain.com:32400\n"
+ "https://192.168.1.100:32400\n"
+ "http://adomain.com:32400\n"
+ "https://adomain.com:32400\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}