using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"k1=(?<k1>\S+)\s+k2=(?<k2>\S+)\s+k3=(?<k3>\S+)\s+k4=(?<k4>\S+)\s+k5=(?<k5>\S+)";
string input = @"msg: ""Service call successful k1=v1 k2=v2 k3=v3 k4=v4 k5=v5 something else can be ignored""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}