import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "k1=(?<k1>\\S+)\\s+k2=(?<k2>\\S+)\\s+k3=(?<k3>\\S+)\\s+k4=(?<k4>\\S+)\\s+k5=(?<k5>\\S+)";
final String string = "msg: \"Service call successful k1=v1 k2=v2 k3=v3 k4=v4 k5=v5 something else can be ignored\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}