using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>(?:.(?!<p>))+<\/div>";
string input = @"""TEXT <p>TEST1</p><br><div> <p>TEST2</p></div>""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}