$re = '/<p>(?:.(?!<p>))+<\/div>/';
$str = '"TEXT <p>TEST1</p><br><div> <p>TEST2</p></div>"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);