using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[2017\/(?:(?!\[\d{4}\/\d{1,2}\/\d)[\s\S])*?ID:00000015fd6c";
string input = @"[2017/4/16 2:28:29AM] (I) Radio mode changed to
SYSAXRADIO_E_STATE_PAGER_RX_SYNC on 170.9 MHz
[2017/4/16 2:28:37AM] Tock = 1718
(I) IDTAG TAG : -90dBm : ID:00000015fd6c
(I) ***************
(I) ID TAG DETECTED 00000015FD6C
(I) ***************";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}