#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?):\s*(.*?)$"
Local $sString = "HTTP/1.1 200 OK" & @CRLF & _
"Content-Type: text/html; charset=utf-8" & @CRLF & _
"Server: hhttpp" & @CRLF & _
"" & @CRLF & _
"<!DOCTYPE HTML>" & @CRLF & _
"<html><body>" & @CRLF & _
"<h1>Hello, World!</h1>" & @CRLF & _
"</body></html>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")