// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?):\s*(.*?)$").unwrap();
let string = "HTTP/1.1 200 OK
Content-Type: text/html; charset=utf-8
Server: hhttpp
<!DOCTYPE HTML>
<html><body>
<h1>Hello, World!</h1>
</body></html>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}