const regex = /@([a-z]|-|[0-9])+\/([a-z]|-|[0-9])+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@([a-z]|-|[0-9])+\\\/([a-z]|-|[0-9])+', 'gm')
const str = `Lorem Ipsum i-s simply @dummy/text of the printing and typesetting industry. Lorem Ipsum has been the industry's @nAme/iNValid text ever since @the/1500s, when an @unknown//printer took a @galley of type and scrambled it to make a type specimen book. It has survived not only five centuries, but also/the leap @into/electronic typesetting, remaining essentially unchanged. It was popularised in the 1960s with the release of Letraset sheets/containing Lorem Ipsum passages, and more recently with desktop publishing software like Aldus PageMaker including versions of Lorem Ipsum`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}