use strict;
my $str = 'Lorem Ipsum i-s simply @dummy/text of the printing and typesetting industry. Lorem Ipsum has been the industry\'s @nAme/iNValid text ever since @the/1500s, when an @unknown//printer took a @galley of type and scrambled it to make a type specimen book. It has survived not only five centuries, but also/the leap @into/electronic typesetting, remaining essentially unchanged. It was popularised in the 1960s with the release of Letraset sheets/containing Lorem Ipsum passages, and more recently with desktop publishing software like Aldus PageMaker including versions of Lorem Ipsum';
my $regex = qr/@([a-z]|-|[0-9])+\/([a-z]|-|[0-9])+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}