#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{8}$)(?![\d-]+$|[a-z-]+$)[^\W_]+(?:-[^\W_]+)+$"
Local $sString = "aa-99-99" & @CRLF & _
"99-23-bd" & @CRLF & _
"02-xx-04" & @CRLF & _
"ab-99-cz" & @CRLF & _
"sc-xd-49" & @CRLF & _
"99-xav-4" & @CRLF & _
"48-xyz-09" & @CRLF & _
"11-11-11" & @CRLF & _
"9-abc-01" & @CRLF & _
"xs-899-x" & @CRLF & _
"sss-99-x"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")