use strict;
my $str = 'aa-99-99
99-23-bd
02-xx-04
ab-99-cz
sc-xd-49
99-xav-4
48-xyz-09
11-11-11
9-abc-01
xs-899-x
sss-99-x';
my $regex = qr/^(?=.{8}$)(?![\d-]+$|[a-z-]+$)[^\W_]+(?:-[^\W_]+)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}