const regex = /({{(.*?)".+".+\|.+\btranslate\b(.*?)}}|\btranslate\b="(.*?)")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({{(.*?)".+".+\\|.+\\btranslate\\b(.*?)}}|\\btranslate\\b="(.*?)")', 'g')
const str = ` <div class="sp-beta-box">
<p class="text-confirm txt-blanc" translate="BI_BOX_TITLE"></p>
<p class="text-big"> </p>
<p class="text-large txt-blanc" translate="BI_BOX_INFOS"></p>
<p class="text-large"> </p>
<p class="text-big txt-blanc" translate="BI_BOX_MSG"></p>
</div>
<div>
<h4 class="txt-blanc" translate="BI_FORM_TITLE"></h4>
</div>
<div class="sp-connect-form txt-blanc">
<div>
<div class="form-label"><p class="text-normal txt-middle">{{"BI_FLD_NAME" | translate}} * :</p></div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}