re = /({{(.*?)".+".+\|.+\btranslate\b(.*?)}}|\btranslate\b="(.*?)")/
str = ' <div class="sp-beta-box">
<p class="text-confirm txt-blanc" translate="BI_BOX_TITLE"></p>
<p class="text-big"> </p>
<p class="text-large txt-blanc" translate="BI_BOX_INFOS"></p>
<p class="text-large"> </p>
<p class="text-big txt-blanc" translate="BI_BOX_MSG"></p>
</div>
<div>
<h4 class="txt-blanc" translate="BI_FORM_TITLE"></h4>
</div>
<div class="sp-connect-form txt-blanc">
<div>
<div class="form-label"><p class="text-normal txt-middle">{{"BI_FLD_NAME" | translate}} * :</p></div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end