// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?:\s+)(?:android:label)(?:=)(?:\")(.*)(?:\")"#).unwrap();
let string = " android:icon=\"@mipmap/ic_launcher\"
android:label=\"Simform Test\"
android:label=\"GetFlamingo\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}