import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bNOT\\h+index=(\"?)\\w+(?:-\\w+)*\\1(*SKIP)(*FAIL)|index=(\"?)\\w+(?:-\\w+)*\\2";
final String string = "tag=os index=linux index=windows NOT index=mac tag=db index=\"a_something-else\" NOT index=solaris\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}