import re
regex = re.compile(r"\bNOT\h+index=(\"?)\w+(?:-\w+)*\1(*SKIP)(*FAIL)|index=(\"?)\w+(?:-\w+)*\2", flags=re.MULTILINE)
test_str = ("tag=os index=linux index=windows NOT index=mac tag=db index=\"a_something-else\" NOT index=solaris\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")